CVE-2026-47761: TinyMCE Cross-Site Scripting (XSS) vulnerability using media plugin `data-mce-object` injection
High · CVSS 8.7 (CVSS 3.1)EPSS 0.26%, 18th percentilePublished Updated Assigner: GitHub_M
Description
TinyMCE is an open source rich text editor. Prior to 5.11.1, 7.9.3, and 8.5.1, there is a stored XSS vulnerability in the media plugin. Attackers can inject malicious scripts via crafted data-mce-* attributes, which are executed when content is rendered. Impacts users of TinyMCE with the media plugin enabled. This vulnerability is fixed in 5.11.1, 7.9.3, and 8.5.1.
Vector CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:N · CWE-79
Tracked companies
Mapped from the CVE’s affected-product data, NVD CPE matches, vendor advisories or package feeds. A mapping means the vendor’s software is named, not that its hosted service was exposed.
Status incidents that name it
No tracked status incident names this CVE.
Affected vendors and products
tinymce: tinymce
References
- CVE record on cve.org (opens in new tab)
- NVD entry (opens in new tab)
- github.com/tinymce/tinymce/security/advisories/GHSA-vg35-5wq7-3x7w (opens in new tab)
- www.tiny.cloud/docs/tinymce/7/7.9.3-release-notes/ (opens in new tab)
- www.tiny.cloud/docs/tinymce/8/8.5.1-release-notes/ (opens in new tab)
- CVE records from the CVE Program (cve.org). CVE® is a registered trademark of The MITRE Corporation. (opens in new tab)
- This product uses data from the NVD API but is not endorsed or certified by the NVD. (opens in new tab)
- Known Exploited Vulnerabilities catalog from CISA. (opens in new tab)
- EPSS scores from FIRST (Exploit Prediction Scoring System). (opens in new tab)