rewindex

RewindexCVEsConfluence

CVE-2025-53689: Apache Jackrabbit: XXE vulnerability in jackrabbit-spi-commons

High · CVSS 8.8 (CVSS 3.1)EPSS 0.54%, 45th percentilePublished Updated Assigner: apache

Description

Blind XXE Vulnerabilities in jackrabbit-spi-commons and jackrabbit-core in Apache Jackrabbit < 2.23.2 due to usage of an unsecured document build to load privileges. Users are recommended to upgrade to versions 2.20.17 (Java 8), 2.22.1 (Java 11) or 2.23.2 (Java 11, beta versions), which fix this issue. Earlier versions (up to 2.20.16) are not supported anymore, thus users should update to the respective supported version.

Vector CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H · CWE-611

Tracked companies

Confluence

Mapped from the CVE’s affected-product data, NVD CPE matches, vendor advisories or package feeds. A mapping means the vendor’s software is named, not that its hosted service was exposed.

Status incidents that name it

No tracked status incident names this CVE.

Affected vendors and products

Apache Software Foundation: Apache Jackrabbit

References

All CVEsMarkdownJSON