rewindex

RewindexCVEsSupabase

CVE-2025-48370: auth-js Vulnerable to Insecure Path Routing from Malformed User Input

Low · CVSS 2.7 (CVSS 4.0)EPSS 0.90%, 59th percentilePublished Updated Assigner: GitHub_M

Description

auth-js is an isomorphic Javascript library for Supabase Auth. Prior to version 2.70.0, the library functions getUserById, deleteUser, updateUserById, listFactors and deleteFactor did not require the user supplied values to be valid UUIDs. This could lead to a URL path traversal, resulting in the wrong API function being called. Implementations that follow security best practice and validate user controlled inputs, such as the userId are not affected by this. This issue has been patched in version 2.70.0.

CWE-22, CWE-287

Tracked companies

Supabase

Mapped from the CVE’s affected-product data, NVD CPE matches, vendor advisories or package feeds. A mapping means the vendor’s software is named, not that its hosted service was exposed.

Status incidents that name it

No tracked status incident names this CVE.

Affected vendors and products

supabase: auth-js

References

All CVEsMarkdownJSON