# CVE-2025-48370: auth-js Vulnerable to Insecure Path Routing from Malformed User Input

> CVE-2025-48370: auth-js Vulnerable to Insecure Path Routing from Malformed User Input. CVSS 2.7 (CVSS 4.0).

Canonical: https://rewindex.com/cve/CVE-2025-48370
Last updated: 2026-07-27T18:46:14Z

- Published: 2025-05-27 15:27 UTC · Updated: 2026-07-27 18:46 UTC · Assigner: GitHub\_M
- CVSS: 2.7 (CVSS 4.0) · Severity: Low
- EPSS: 0.90%, 59th percentile (scored 2026-10-25)
- CISA KEV: no
- CWE: CWE-22, CWE-287

## Description

auth-js is an isomorphic Javascript library for Supabase Auth. Prior to version 2.70.0, the library functions getUserById, deleteUser, updateUserById, listFactors and deleteFactor did not require the user supplied values to be valid UUIDs. This could lead to a URL path traversal, resulting in the wrong API function being called. Implementations that follow security best practice and validate user controlled inputs, such as the userId are not affected by this. This issue has been patched in version 2.70.0.

## Affected vendors and products

- supabase: auth-js

## Tracked companies

- [Supabase](https://rewindex.com/company/supabase.md)

## References

- [CVE record on cve.org](https://www.cve.org/CVERecord?id=CVE-2025-48370)
- [NVD entry](https://nvd.nist.gov/vuln/detail/CVE-2025-48370)
- [https://github.com/supabase/auth-js/commit/1bcb76e479e51cd9bca2d7732d0bf3199e07a693](https://github.com/supabase/auth-js/commit/1bcb76e479e51cd9bca2d7732d0bf3199e07a693)
- [https://github.com/supabase/auth-js/pull/1063](https://github.com/supabase/auth-js/pull/1063)
- [https://github.com/supabase/auth-js/security/advisories/GHSA-8r88-6cj9-9fh5](https://github.com/supabase/auth-js/security/advisories/GHSA-8r88-6cj9-9fh5)

---

_Sources: CVE records from the CVE Program (cve.org). CVE® is a registered trademark of The MITRE Corporation. (https://www.cve.org/) This product uses data from the NVD API but is not endorsed or certified by the NVD. (https://nvd.nist.gov/) Known Exploited Vulnerabilities catalog from CISA. (https://www.cisa.gov/known-exploited-vulnerabilities-catalog) EPSS scores from FIRST (Exploit Prediction Scoring System). (https://www.first.org/epss/)_


---
Canonical: https://rewindex.com/cve/CVE-2025-48370 · Markdown: https://rewindex.com/cve/CVE-2025-48370.md · JSON: https://rewindex.com/api/v1/cves/CVE-2025-48370 · Data licensed CC BY 4.0 (https://creativecommons.org/licenses/by/4.0/) · Generated 2026-10-26T03:11:13.884Z
