CVE-2026-64642: Next.js: Middleware / Proxy bypass in App Router applications using Turbopack and single locale
High · CVSS 8.2 (CVSS 3.1)EPSS 0.63%, 50th percentilePublished Updated Assigner: GitHub_M
Description
Next.js is a React framework for building full-stack web applications. In versions 16.0.0 through 16.2.10, crafted requests targeting Next.js applications using App Router built with Turbopack and a single entry in config.i18n.locales can bypass middleware/proxy based authentication. This issue has been fixed in version 16.2.11.
Vector CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:L/A:N · CWE-285
Tracked companies
Mapped from the CVE’s affected-product data, NVD CPE matches, vendor advisories or package feeds. A mapping means the vendor’s software is named, not that its hosted service was exposed.
Status incidents that name it
No tracked status incident names this CVE.
Affected vendors and products
vercel: next.js
References
- CVE record on cve.org (opens in new tab)
- NVD entry (opens in new tab)
- github.com/vercel/next.js/commit/6bf4df14508ad6c0cd46af50c6051ee42f2d9151 (opens in new tab)
- github.com/vercel/next.js/pull/96014 (opens in new tab)
- github.com/vercel/next.js/releases/tag/v16.2.11 (opens in new tab)
- github.com/vercel/next.js/security/advisories/GHSA-6gpp-xcg3-4w24 (opens in new tab)
- CVE records from the CVE Program (cve.org). CVE® is a registered trademark of The MITRE Corporation. (opens in new tab)
- This product uses data from the NVD API but is not endorsed or certified by the NVD. (opens in new tab)
- Known Exploited Vulnerabilities catalog from CISA. (opens in new tab)
- EPSS scores from FIRST (Exploit Prediction Scoring System). (opens in new tab)