CVE-2026-44575: Next.js: Middleware / Proxy bypass in App Router applications via segment-prefetch routes
Description
Next.js is a React framework for building full-stack web applications. From 15.2.0 to before 15.5.16 and 16.2.5, App Router applications that rely on middleware or proxy-based checks for authorization can allow unauthorized access through transport-specific route variants used for segment prefetching. In affected configurations, specially crafted .rsc and segment-prefetch URLs can resolve to the same page without being matched by the intended middleware rule, which can allow protected content to be reached without the expected authorization check. This vulnerability is fixed in 15.5.16 and 16.2.5.
Vector CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N · CWE-288
Tracked companies
Mapped from the CVE’s affected-product data, NVD CPE matches, vendor advisories or package feeds. A mapping means the vendor’s software is named, not that its hosted service was exposed.
Status incidents that name it
No tracked status incident names this CVE.
Affected vendors and products
Red Hat: Red Hat Enterprise Linux 10Red Hat: Red Hat Enterprise Linux 7Red Hat: Red Hat Enterprise Linux 8Red Hat: Red Hat Enterprise Linux 9Red Hat: Red Hat Enterprise Linux AI (RHEL AI) 3Red Hat: Red Hat Trusted Artifact Signer 1.3Red Hat: Red Hat Trusted Artifact Signer 1.4Red Hat: Streams for Apache Kafka 2.9.4Red Hat: streams for Apache Kafka 3vercel: next.js
References
- CVE record on cve.org (opens in new tab)
- NVD entry (opens in new tab)
- github.com/vercel/next.js/security/advisories/GHSA-267c-6grr-h53f (opens in new tab)
- CVE records from the CVE Program (cve.org). CVE® is a registered trademark of The MITRE Corporation. (opens in new tab)
- This product uses data from the NVD API but is not endorsed or certified by the NVD. (opens in new tab)
- Known Exploited Vulnerabilities catalog from CISA. (opens in new tab)
- EPSS scores from FIRST (Exploit Prediction Scoring System). (opens in new tab)