CVE-2026-42354: Sentry: Improper authentication on SAML SSO process allows user identity linking
Description
Sentry is an error tracking and performance monitoring tool. From version 21.12.0 to before version 26.4.1, a critical vulnerability was discovered in the SAML SSO implementation of Sentry. The vulnerability allows an attacker to take over any user account by using a malicious SAML Identity Provider and another organization on the same Sentry instance. The victim email address must be known in order to exploit this vulnerability. This issue has been patched in version 26.4.1.
Vector CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N · CWE-290
Tracked companies
Mapped from the CVE’s affected-product data, NVD CPE matches, vendor advisories or package feeds. A mapping means the vendor’s software is named, not that its hosted service was exposed.
Status incidents that name it
No tracked status incident names this CVE.
Affected vendors and products
getsentry: sentry
References
- CVE record on cve.org (opens in new tab)
- NVD entry (opens in new tab)
- github.com/getsentry/sentry/commit/0c67558ae7fe08738912d4c5233b53ead048da3b (opens in new tab)
- github.com/getsentry/sentry/pull/113720 (opens in new tab)
- github.com/getsentry/sentry/releases/tag/26.4.1 (opens in new tab)
- github.com/getsentry/sentry/security/advisories/GHSA-rcmw-7mc7-3rj7 (opens in new tab)
- CVE records from the CVE Program (cve.org). CVE® is a registered trademark of The MITRE Corporation. (opens in new tab)
- This product uses data from the NVD API but is not endorsed or certified by the NVD. (opens in new tab)
- Known Exploited Vulnerabilities catalog from CISA. (opens in new tab)
- EPSS scores from FIRST (Exploit Prediction Scoring System). (opens in new tab)