CVE-2026-42271: LiteLLM: Authenticated command execution via MCP stdio test endpoints
In CISA’s Known Exploited Vulnerabilities catalog: BerriAI LiteLLM Command Injection Vulnerability.
Added , federal remediation due . Known ransomware use: Unknown.
Required action: Apply mitigations per vendor instructions, follow applicable BOD 22-01 guidance for cloud services, or discontinue use of the product if mitigations are unavailable.
Description
LiteLLM is a proxy server (AI Gateway) to call LLM APIs in OpenAI (or native) format. From version 1.74.2 to before version 1.83.7, two endpoints used to preview an MCP server before saving it — POST /mcp-rest/test/connection and POST /mcp-rest/test/tools/list — accepted a full server configuration in the request body, including the command, args, and env fields used by the stdio transport. When called with a stdio configuration, the endpoints attempted to connect, which spawned the supplied command as a subprocess on the proxy host with the privileges of the proxy process. The endpoints were gated only by a valid proxy API key, with no role check. Any authenticated user — including holders of low-privilege internal-user keys — could therefore run arbitrary commands on the host. This issue has been patched in version 1.83.7.
Vector CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H · CWE-77, CWE-78
Status incidents that name it
No tracked status incident names this CVE.
Affected vendors and products
BerriAI: litellmRed Hat: Exploit IntelligenceRed Hat: Red Hat Ansible Automation Platform 2Red Hat: Red Hat OpenShift AI 2.25Red Hat: Red Hat OpenShift AI 3.3Red Hat: Red Hat OpenShift AI 3.4Red Hat: Red Hat OpenShift AI (RHOAI)
References
- CVE record on cve.org (opens in new tab)
- NVD entry (opens in new tab)
- github.com/BerriAI/litellm/releases/tag/v1.83.7-stable (opens in new tab)
- github.com/BerriAI/litellm/security/advisories/GHSA-v4p8-mg3p-g94g (opens in new tab)
- CVE records from the CVE Program (cve.org). CVE® is a registered trademark of The MITRE Corporation. (opens in new tab)
- This product uses data from the NVD API but is not endorsed or certified by the NVD. (opens in new tab)
- Known Exploited Vulnerabilities catalog from CISA. (opens in new tab)
- EPSS scores from FIRST (Exploit Prediction Scoring System). (opens in new tab)