CVE-2026-42208: LiteLLM: SQL injection in Proxy API key verification
In CISA’s Known Exploited Vulnerabilities catalog: BerriAI LiteLLM SQL Injection Vulnerability.
Added , federal remediation due . Known ransomware use: Unknown.
Required action: Apply mitigations per vendor instructions, follow applicable BOD 22-01 guidance for cloud services, or discontinue use of the product if mitigations are unavailable.
Description
LiteLLM is a proxy server (AI Gateway) to call LLM APIs in OpenAI (or native) format. From version 1.81.16 to before version 1.83.7, a database query used during proxy API key checks mixed the caller-supplied key value into the query text instead of passing it as a separate parameter. An unauthenticated attacker could send a specially crafted Authorization header to any LLM API route (for example POST /chat/completions) and reach this query through the proxy's error-handling path. An attacker could read data from the proxy's database and may be able to modify it, leading to unauthorised access to the proxy and the credentials it manages. This issue has been patched in version 1.83.7.
Vector CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H · CWE-89
Status incidents that name it
No tracked status incident names this CVE.
Affected vendors and products
BerriAI: litellmRed Hat: Lightspeed CoreRed Hat: Red Hat Ansible Automation Platform 2Red Hat: Red Hat OpenShift AI (RHOAI)
References
- CVE record on cve.org (opens in new tab)
- NVD entry (opens in new tab)
- github.com/BerriAI/litellm/releases/tag/v1.83.7-stable (opens in new tab)
- github.com/BerriAI/litellm/security/advisories/GHSA-r75f-5x8p-qvmc (opens in new tab)
- CVE records from the CVE Program (cve.org). CVE® is a registered trademark of The MITRE Corporation. (opens in new tab)
- This product uses data from the NVD API but is not endorsed or certified by the NVD. (opens in new tab)
- Known Exploited Vulnerabilities catalog from CISA. (opens in new tab)
- EPSS scores from FIRST (Exploit Prediction Scoring System). (opens in new tab)