CVE-2026-34236: Auth0 PHP SDK Insufficient Entropy in Cookie Encryption
High · CVSS 8.2 (CVSS 3.1)EPSS 0.22%, 13th percentilePublished Updated Assigner: GitHub_M
Description
Auth0-PHP is a PHP SDK for Auth0 Authentication and Management APIs. From version 8.0.0 to before version 8.19.0, in applications built with the Auth0 PHP SDK, cookies are encrypted with insufficient entropy, which may result in threat actors brute-forcing the encryption key and forging session cookies. This issue has been patched in version 8.19.0.
Vector CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:C/C:H/I:H/A:N · CWE-331
Tracked companies
Mapped from the CVE’s affected-product data, NVD CPE matches, vendor advisories or package feeds. A mapping means the vendor’s software is named, not that its hosted service was exposed.
Status incidents that name it
No tracked status incident names this CVE.
Affected vendors and products
auth0: auth0-PHP
References
- CVE record on cve.org (opens in new tab)
- NVD entry (opens in new tab)
- github.com/auth0/auth0-PHP/releases/tag/8.19.0 (opens in new tab)
- github.com/auth0/auth0-PHP/security/advisories/GHSA-w3wc-44p4-m4j7 (opens in new tab)
- CVE records from the CVE Program (cve.org). CVE® is a registered trademark of The MITRE Corporation. (opens in new tab)
- This product uses data from the NVD API but is not endorsed or certified by the NVD. (opens in new tab)
- Known Exploited Vulnerabilities catalog from CISA. (opens in new tab)
- EPSS scores from FIRST (Exploit Prediction Scoring System). (opens in new tab)