CVE-2026-33997: Moby: Off-by-one error in plugin privilege validation
Description
Moby is an open source container framework. Prior to version 29.3.1, a security vulnerability has been detected that allows plugins privilege validation to be bypassed during docker plugin install. Due to an error in the daemon's privilege comparison logic, the daemon may incorrectly accept a privilege set that differs from the one approved by the user. Plugins that request exactly one privilege are also affected, because no comparison is performed at all. This issue has been patched in version 29.3.1.
Vector CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:N · CWE-193
Tracked companies
Mapped from the CVE’s affected-product data, NVD CPE matches, vendor advisories or package feeds. A mapping means the vendor’s software is named, not that its hosted service was exposed.
Status incidents that name it
No tracked status incident names this CVE.
Affected vendors and products
moby: mobyRed Hat: Multicluster Engine for KubernetesRed Hat: Multicluster Global Hub 1.4.5Red Hat: Multicluster Global Hub 1.6.5Red Hat: OpenShift Service Mesh 2Red Hat: Red Hat Advanced Cluster Management for Kubernetes 2Red Hat: Red Hat multicluster global hub 1.5.3Red Hat: Red Hat OpenShift Container Platform 4Red Hat: Red Hat OpenShift Virtualization 4
References
- CVE record on cve.org (opens in new tab)
- NVD entry (opens in new tab)
- github.com/moby/moby/releases/tag/docker-v29.3.1 (opens in new tab)
- github.com/moby/moby/security/advisories/GHSA-pxq6-2prw-chj9 (opens in new tab)
- CVE records from the CVE Program (cve.org). CVE® is a registered trademark of The MITRE Corporation. (opens in new tab)
- This product uses data from the NVD API but is not endorsed or certified by the NVD. (opens in new tab)
- Known Exploited Vulnerabilities catalog from CISA. (opens in new tab)
- EPSS scores from FIRST (Exploit Prediction Scoring System). (opens in new tab)