CVE-2026-19589: Packer vulnerable to arbitrary file write via crafted plugin archive during installation
High · CVSS 7.1 (CVSS 3.1)EPSS 0.19%, 9th percentilePublished Updated Assigner: HashiCorp
Description
Packer up to 1.15.4 is vulnerable to an issue in the third-party plugin installer that may allow unintended file system modification and could lead to code execution. A user who installs a plugin from a malicious or compromised source may be affected. This vulnerability (CVE-2026-19589) is fixed in Packer 1.16.0.
Vector CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:C/C:L/I:H/A:N · CWE-22
Tracked companies
Mapped from the CVE’s affected-product data, NVD CPE matches, vendor advisories or package feeds. A mapping means the vendor’s software is named, not that its hosted service was exposed.
Status incidents that name it
No tracked status incident names this CVE.
Affected vendors and products
HashiCorp: Packer
References
- CVE record on cve.org (opens in new tab)
- NVD entry (opens in new tab)
- discuss.hashicorp.com/t/hcsec-2026-29-packer-vulnerable-to-arbitrary-file-write-via-crafted… (opens in new tab)
- CVE records from the CVE Program (cve.org). CVE® is a registered trademark of The MITRE Corporation. (opens in new tab)
- This product uses data from the NVD API but is not endorsed or certified by the NVD. (opens in new tab)
- Known Exploited Vulnerabilities catalog from CISA. (opens in new tab)
- EPSS scores from FIRST (Exploit Prediction Scoring System). (opens in new tab)