CVE-2026-15007: Denial of service vulnerability in GitHub Enterprise Server allowed service disruption via deeply nested YAML in release notes configuration
Description
A denial of service vulnerability was identified in GitHub Enterprise Server that allowed an authenticated user to cause service disruption by supplying a repository release notes configuration file containing deeply nested YAML. When release notes were generated, the configuration file was parsed without a nesting depth limit, causing excessive resource consumption that could render the instance unresponsive. This vulnerability affected all versions of GitHub Enterprise Server prior to 3.22 and was fixed in versions 3.17.18, 3.18.12, 3.19.9, 3.20.5, and 3.21.3. This vulnerability was reported via the GitHub Bug Bounty program.
CWE-770
Tracked companies
Mapped from the CVE’s affected-product data, NVD CPE matches, vendor advisories or package feeds. A mapping means the vendor’s software is named, not that its hosted service was exposed.
Status incidents that name it
No tracked status incident names this CVE.
Affected vendors and products
GitHub: Enterprise Server
References
- CVE record on cve.org (opens in new tab)
- NVD entry (opens in new tab)
- docs.github.com/en/enterprise-server@3.17/admin/release-notes (opens in new tab)
- docs.github.com/en/enterprise-server@3.18/admin/release-notes (opens in new tab)
- docs.github.com/en/enterprise-server@3.19/admin/release-notes (opens in new tab)
- docs.github.com/en/enterprise-server@3.20/admin/release-notes (opens in new tab)
- docs.github.com/en/enterprise-server@3.21/admin/release-notes (opens in new tab)
- CVE records from the CVE Program (cve.org). CVE® is a registered trademark of The MITRE Corporation. (opens in new tab)
- This product uses data from the NVD API but is not endorsed or certified by the NVD. (opens in new tab)
- Known Exploited Vulnerabilities catalog from CISA. (opens in new tab)
- EPSS scores from FIRST (Exploit Prediction Scoring System). (opens in new tab)