CVE-2025-8447: Incorrect authorization vulnerability was identified in GitHub Enterprise Server that allowed read-only access
Description
An improper access control vulnerability was identified in GitHub Enterprise Server that allowed users with access to any repository to retrieve limited code content from another repository by creating a diff between the repositories. To exploit this vulnerability, an attacker needed to know the name of a private repository along with its branches, tags, or commit SHAs that they could use to trigger compare/diff functionality and retrieve limited code without proper authorization. This vulnerability affected all versions of GitHub Enterprise Server prior to 3.18, and was fixed in versions 3.14.17, 3.15.12, 3.16.8 and 3.17.5. This vulnerability was reported via the GitHub Bug Bounty program.
Vector CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:L/I:N/A:N · CWE-639
Tracked companies
Mapped from the CVE’s affected-product data, NVD CPE matches, vendor advisories or package feeds. A mapping means the vendor’s software is named, not that its hosted service was exposed.
Status incidents that name it
No tracked status incident names this CVE.
Affected vendors and products
GitHub: Enterprise Server
References
- CVE record on cve.org (opens in new tab)
- NVD entry (opens in new tab)
- docs.github.com/en/enterprise-server@3.14/admin/release-notes (opens in new tab)
- docs.github.com/en/enterprise-server@3.15/admin/release-notes (opens in new tab)
- docs.github.com/en/enterprise-server@3.16/admin/release-notes (opens in new tab)
- docs.github.com/en/enterprise-server@3.17/admin/release-notes (opens in new tab)
- CVE records from the CVE Program (cve.org). CVE® is a registered trademark of The MITRE Corporation. (opens in new tab)
- This product uses data from the NVD API but is not endorsed or certified by the NVD. (opens in new tab)
- Known Exploited Vulnerabilities catalog from CISA. (opens in new tab)
- EPSS scores from FIRST (Exploit Prediction Scoring System). (opens in new tab)