CVE-2025-6981: Incorrect authorization vulnerability was identified in GitHub Enterprise Server that allowed unauthorized read-only access
Medium · CVSS 4.3 (CVSS 3.1)EPSS 0.31%, 23th percentilePublished Updated Assigner: GitHub_P
Description
An incorrect authorization vulnerability allowed unauthorized read access to the contents of internal repositories for contractor accounts when the Contractors API feature was enabled. The Contractors API is a rarely-enabled feature in private preview. This vulnerability affected all versions of GitHub Enterprise Server prior to 3.18 and was fixed in versions 3.14.15, 3.15.10, 3.16.6 and 3.17.3
Vector CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N · CWE-863
Tracked companies
Mapped from the CVE’s affected-product data, NVD CPE matches, vendor advisories or package feeds. A mapping means the vendor’s software is named, not that its hosted service was exposed.
Status incidents that name it
No tracked status incident names this CVE.
Affected vendors and products
GitHub: Enterprise Server
References
- CVE record on cve.org (opens in new tab)
- NVD entry (opens in new tab)
- docs.github.com/en/enterprise-server@3.14/admin/release-notes (opens in new tab)
- docs.github.com/en/enterprise-server@3.15/admin/release-notes (opens in new tab)
- docs.github.com/en/enterprise-server@3.16/admin/release-notes (opens in new tab)
- docs.github.com/en/enterprise-server@3.17/admin/release-notes (opens in new tab)
- CVE records from the CVE Program (cve.org). CVE® is a registered trademark of The MITRE Corporation. (opens in new tab)
- This product uses data from the NVD API but is not endorsed or certified by the NVD. (opens in new tab)
- Known Exploited Vulnerabilities catalog from CISA. (opens in new tab)
- EPSS scores from FIRST (Exploit Prediction Scoring System). (opens in new tab)