CVE-2025-67716: Auth0 Next.js SDK has Improper Validation of Query Parameters
Medium · CVSS 5.7 (CVSS 3.1)EPSS 0.26%, 18th percentilePublished Updated Assigner: GitHub_M
Description
The Auth0 Next.js SDK is a library for implementing user authentication in Next.js applications. Versions 4.9.0 through 4.12.1 contain an input-validation flaw in the returnTo parameter, which could allow attackers to inject unintended OAuth query parameters into the Auth0 authorization request. Successful exploitation may result in tokens being issued with unintended parameters. This issue is fixed in version 4.13.0.
Vector CVSS:3.1/AV:N/AC:H/PR:H/UI:R/S:U/C:H/I:H/A:N · CWE-184
Tracked companies
Mapped from the CVE’s affected-product data, NVD CPE matches, vendor advisories or package feeds. A mapping means the vendor’s software is named, not that its hosted service was exposed.
Status incidents that name it
No tracked status incident names this CVE.
Affected vendors and products
auth0: nextjs-auth0
References
- CVE record on cve.org (opens in new tab)
- NVD entry (opens in new tab)
- github.com/auth0/nextjs-auth0/commit/35eb321de3345ccf23e8c0d6f66c9f2f2f57d26c (opens in new tab)
- github.com/auth0/nextjs-auth0/security/advisories/GHSA-mr6f-h57v-rpj5 (opens in new tab)
- CVE records from the CVE Program (cve.org). CVE® is a registered trademark of The MITRE Corporation. (opens in new tab)
- This product uses data from the NVD API but is not endorsed or certified by the NVD. (opens in new tab)
- Known Exploited Vulnerabilities catalog from CISA. (opens in new tab)
- EPSS scores from FIRST (Exploit Prediction Scoring System). (opens in new tab)