CVE-2025-58769: auth0-PHP: Improper File Type Handling in Bulk User Import
Description
auth0-PHP is an SDK for Auth0 Authentication and Management APIs. In versions 3.3.0 through 8.16.0, the Bulk User Import endpoint in applications built with the SDK does not validate the file-path wrapper or value. Without proper validation, affected applications may accept arbitrary file paths or URLs. The vulnerability affects any application that either directly uses the Auth0-PHP SDK (versions 3.3.0–8.16.0) or indirectly relies on those versions through the Auth0/symfony, Auth0/laravel-auth0, or Auth0/wordpress SDKs. This issue is fixed in version 8.17.0.
Vector CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:U/C:L/I:L/A:N · CWE-22, CWE-73
Tracked companies
Mapped from the CVE’s affected-product data, NVD CPE matches, vendor advisories or package feeds. A mapping means the vendor’s software is named, not that its hosted service was exposed.
Status incidents that name it
No tracked status incident names this CVE.
Affected vendors and products
auth0: laravel-auth0
References
- CVE record on cve.org (opens in new tab)
- NVD entry (opens in new tab)
- github.com/auth0/auth0-PHP/commit/9026da58f5c381cd4cb5932de829eff6eacbb65c (opens in new tab)
- github.com/auth0/auth0-PHP/releases/tag/8.17.0 (opens in new tab)
- github.com/auth0/auth0-PHP/security/advisories/GHSA-9mh6-g99m-ppcw (opens in new tab)
- github.com/auth0/laravel-auth0/security/advisories/GHSA-hjfh-5jmm-xr24 (opens in new tab)
- github.com/auth0/symfony/security/advisories/GHSA-7jp2-5h22-m432 (opens in new tab)
- github.com/auth0/wordpress/security/advisories/GHSA-w22c-pw5m-482x (opens in new tab)
- CVE records from the CVE Program (cve.org). CVE® is a registered trademark of The MITRE Corporation. (opens in new tab)
- This product uses data from the NVD API but is not endorsed or certified by the NVD. (opens in new tab)
- Known Exploited Vulnerabilities catalog from CISA. (opens in new tab)
- EPSS scores from FIRST (Exploit Prediction Scoring System). (opens in new tab)