CVE-2025-58360: GeoServer is vulnerable to an Unauthenticated XML External Entities (XXE) attack via WMS GetMap feature
In CISA’s Known Exploited Vulnerabilities catalog: OSGeo GeoServer Improper Restriction of XML External Entity Reference Vulnerability.
Added , federal remediation due . Known ransomware use: Unknown.
Required action: Apply mitigations per vendor instructions, follow applicable BOD 22-01 guidance for cloud services, or discontinue use of the product if mitigations are unavailable.
Description
GeoServer is an open source server that allows users to share and edit geospatial data. From version 2.26.0 to before 2.26.2 and before 2.25.6, an XML External Entity (XXE) vulnerability was identified. The application accepts XML input through a specific endpoint /geoserver/wms operation GetMap. However, this input is not sufficiently sanitized or restricted, allowing an attacker to define external entities within the XML request. This issue has been patched in GeoServer 2.25.6, GeoServer 2.26.3, and GeoServer 2.27.0.
Vector CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:L · CWE-611
Status incidents that name it
No tracked status incident names this CVE.
Affected vendors and products
geoserver: geoserver
References
- CVE record on cve.org (opens in new tab)
- NVD entry (opens in new tab)
- github.com/geoserver/geoserver/security/advisories/GHSA-fjf5-xgmq-5525 (opens in new tab)
- osgeo-org.atlassian.net/browse/GEOS-11682 (opens in new tab)
- CVE records from the CVE Program (cve.org). CVE® is a registered trademark of The MITRE Corporation. (opens in new tab)
- This product uses data from the NVD API but is not endorsed or certified by the NVD. (opens in new tab)
- Known Exploited Vulnerabilities catalog from CISA. (opens in new tab)
- EPSS scores from FIRST (Exploit Prediction Scoring System). (opens in new tab)