CVE-2025-57752: Next.js Affected by Cache Key Confusion for Image Optimization API Routes
Description
Next.js is a React framework for building full-stack web applications. In versions before 14.2.31 and from 15.0.0 to before 15.4.5, Next.js Image Optimization API routes are affected by cache key confusion. When images returned from API routes vary based on request headers (such as Cookie or Authorization), these responses could be incorrectly cached and served to unauthorized users due to a cache key confusion bug. This vulnerability has been fixed in Next.js versions 14.2.31 and 15.4.5. All users are encouraged to upgrade if they use API routes to serve images that depend on request headers and have image optimization enabled.
Vector CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N · CWE-524
Tracked companies
Mapped from the CVE’s affected-product data, NVD CPE matches, vendor advisories or package feeds. A mapping means the vendor’s software is named, not that its hosted service was exposed.
Status incidents that name it
No tracked status incident names this CVE.
Affected vendors and products
vercel: next.js
References
- CVE record on cve.org (opens in new tab)
- NVD entry (opens in new tab)
- github.com/vercel/next.js/commit/6b12c60c61ee80cb0443ccd20de82ca9b4422ddd (opens in new tab)
- github.com/vercel/next.js/pull/82114 (opens in new tab)
- github.com/vercel/next.js/security/advisories/GHSA-g5qg-72qw-gw5v (opens in new tab)
- vercel.com/changelog/cve-2025-57752 (opens in new tab)
- CVE records from the CVE Program (cve.org). CVE® is a registered trademark of The MITRE Corporation. (opens in new tab)
- This product uses data from the NVD API but is not endorsed or certified by the NVD. (opens in new tab)
- Known Exploited Vulnerabilities catalog from CISA. (opens in new tab)
- EPSS scores from FIRST (Exploit Prediction Scoring System). (opens in new tab)