CVE-2025-55282: aiven-db-migrate allows Privilege Escalation via unrestricted search_path during migration
Critical · CVSS 9.1 (CVSS 3.1)EPSS 0.72%, 54th percentilePublished Updated Assigner: GitHub_M
Description
aiven-db-migrate is an Aiven database migration tool. Prior to 1.0.7, there is a privilege escalation vulnerability that allows a user to elevate to superuser inside PostgreSQL databases during a migration from an untrusted source server. By exploiting a lack of search_path restriction, an attacker can override pg_catalog and execute untrusted operators as a superuser. This vulnerability is fixed in 1.0.7.
Vector CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:H/I:H/A:H · CWE-22
Tracked companies
Mapped from the CVE’s affected-product data, NVD CPE matches, vendor advisories or package feeds. A mapping means the vendor’s software is named, not that its hosted service was exposed.
Status incidents that name it
No tracked status incident names this CVE.
Affected vendors and products
aiven: aiven-db-migrate
References
- CVE record on cve.org (opens in new tab)
- NVD entry (opens in new tab)
- github.com/aiven/aiven-db-migrate/commit/39517dc55720055d93262033b142a365f5bf92c… (opens in new tab)
- github.com/aiven/aiven-db-migrate/security/advisories/GHSA-hmvf-93r4-36f9 (opens in new tab)
- CVE records from the CVE Program (cve.org). CVE® is a registered trademark of The MITRE Corporation. (opens in new tab)
- This product uses data from the NVD API but is not endorsed or certified by the NVD. (opens in new tab)
- Known Exploited Vulnerabilities catalog from CISA. (opens in new tab)
- EPSS scores from FIRST (Exploit Prediction Scoring System). (opens in new tab)