CVE-2025-46817: Lua library commands may lead to integer overflow and potential RCE
High · CVSS 7.0 (CVSS 3.1)EPSS 3.9%, 90th percentilePublished Updated Assigner: GitHub_M
Description
Redis is an open source, in-memory database that persists on disk. Versions 8.2.1 and below allow an authenticated user to use a specially crafted Lua script to cause an integer overflow and potentially lead to remote code execution The problem exists in all versions of Redis with Lua scripting. This issue is fixed in version 8.2.2.
Vector CVSS:3.1/AV:L/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H · CWE-190
Tracked companies
Mapped from the CVE’s affected-product data, NVD CPE matches, vendor advisories or package feeds. A mapping means the vendor’s software is named, not that its hosted service was exposed.
Status incidents that name it
No tracked status incident names this CVE.
Affected vendors and products
redis: redis
References
- CVE record on cve.org (opens in new tab)
- NVD entry (opens in new tab)
- github.com/redis/redis/commit/fc9abc775e308374f667fdf3e723ef4b7eb0e3ca (opens in new tab)
- github.com/redis/redis/releases/tag/8.2.2 (opens in new tab)
- github.com/redis/redis/security/advisories/GHSA-m8fj-85cg-7vhp (opens in new tab)
- CVE records from the CVE Program (cve.org). CVE® is a registered trademark of The MITRE Corporation. (opens in new tab)
- This product uses data from the NVD API but is not endorsed or certified by the NVD. (opens in new tab)
- Known Exploited Vulnerabilities catalog from CISA. (opens in new tab)
- EPSS scores from FIRST (Exploit Prediction Scoring System). (opens in new tab)