CVE-2025-46344: Auth0 NextJS SDK v4 Missing Session Invalidation
Medium · CVSS 4.9 (CVSS 4.0)EPSS 0.43%, 37th percentilePublished Updated Assigner: GitHub_M
Description
The Auth0 Next.js SDK is a library for implementing user authentication in Next.js applications. Versions starting from 4.0.1 and prior to 4.5.1, do not invoke `.setExpirationTime` when generating a JWE token for the session. As a result, the JWE does not contain an internal expiration claim. While the session cookie may expire or be cleared, the JWE remains valid. This issue has been patched in version 4.5.1.
CWE-613
Tracked companies
Mapped from the CVE’s affected-product data, NVD CPE matches, vendor advisories or package feeds. A mapping means the vendor’s software is named, not that its hosted service was exposed.
Status incidents that name it
No tracked status incident names this CVE.
Affected vendors and products
auth0: nextjs-auth0
References
- CVE record on cve.org (opens in new tab)
- NVD entry (opens in new tab)
- github.com/auth0/nextjs-auth0/commit/a4f061aed02ffa132feca8adfbd11704df17e1c3 (opens in new tab)
- github.com/auth0/nextjs-auth0/releases/tag/v4.5.1 (opens in new tab)
- github.com/auth0/nextjs-auth0/security/advisories/GHSA-pjr6-jx7r-j4r6 (opens in new tab)
- CVE records from the CVE Program (cve.org). CVE® is a registered trademark of The MITRE Corporation. (opens in new tab)
- This product uses data from the NVD API but is not endorsed or certified by the NVD. (opens in new tab)
- Known Exploited Vulnerabilities catalog from CISA. (opens in new tab)
- EPSS scores from FIRST (Exploit Prediction Scoring System). (opens in new tab)