CVE-2025-24791: snowflake-connector-nodejs has incorrect validation of temporary credential cache file permissions
Medium · CVSS 4.4 (CVSS 3.1)EPSS 0.15%, 4th percentilePublished Updated Assigner: GitHub_M
Description
snowflake-connector-nodejs is a NodeJS driver for Snowflake. Snowflake discovered and remediated a vulnerability in the Snowflake NodeJS Driver. File permissions checks of the temporary credential cache could be bypassed by an attacker with write access to the local cache directory. This vulnerability affects versions 1.12.0 through 2.0.1 on Linux. Snowflake fixed the issue in version 2.0.2.
Vector CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:N · CWE-281
Tracked companies
Mapped from the CVE’s affected-product data, NVD CPE matches, vendor advisories or package feeds. A mapping means the vendor’s software is named, not that its hosted service was exposed.
Status incidents that name it
No tracked status incident names this CVE.
Affected vendors and products
snowflakedb: snowflake-connector-nodejs
References
- CVE record on cve.org (opens in new tab)
- NVD entry (opens in new tab)
- github.com/snowflakedb/snowflake-connector-nodejs/commit/89731b3a4d61a75b721d13d… (opens in new tab)
- github.com/snowflakedb/snowflake-connector-nodejs/security/advisories/GHSA-xfhv-… (opens in new tab)
- CVE records from the CVE Program (cve.org). CVE® is a registered trademark of The MITRE Corporation. (opens in new tab)
- This product uses data from the NVD API but is not endorsed or certified by the NVD. (opens in new tab)
- Known Exploited Vulnerabilities catalog from CISA. (opens in new tab)
- EPSS scores from FIRST (Exploit Prediction Scoring System). (opens in new tab)