CVE-2024-8810: Privilege Management vulnerability was identified in GitHub Enterprise Server that allowed GitHub Apps to grant themselves write access
Description
A GitHub App installed in organizations could upgrade some permissions from read to write access without approval from an organization administrator. An attacker would require an account with administrator access to install a malicious GitHub App. This vulnerability affected all versions of GitHub Enterprise Server prior to 3.14 and was fixed in versions 3.14.1, 3.13.4, 3.12.9, 3.11.15, and 3.10.17. This vulnerability was reported via the GitHub Bug Bounty program.
Vector CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:N · CWE-269
Tracked companies
Mapped from the CVE’s affected-product data, NVD CPE matches, vendor advisories or package feeds. A mapping means the vendor’s software is named, not that its hosted service was exposed.
Status incidents that name it
No tracked status incident names this CVE.
Affected vendors and products
github: enterprise_serverGitHub: Enterprise Server
References
- CVE record on cve.org (opens in new tab)
- NVD entry (opens in new tab)
- docs.github.com/en/enterprise-server@3.10/admin/release-notes (opens in new tab)
- docs.github.com/en/enterprise-server@3.11/admin/release-notes (opens in new tab)
- docs.github.com/en/enterprise-server@3.12/admin/release-notes (opens in new tab)
- docs.github.com/en/enterprise-server@3.13/admin/release-notes (opens in new tab)
- docs.github.com/en/enterprise-server@3.14/admin/release-notes (opens in new tab)
- CVE records from the CVE Program (cve.org). CVE® is a registered trademark of The MITRE Corporation. (opens in new tab)
- This product uses data from the NVD API but is not endorsed or certified by the NVD. (opens in new tab)
- Known Exploited Vulnerabilities catalog from CISA. (opens in new tab)
- EPSS scores from FIRST (Exploit Prediction Scoring System). (opens in new tab)