CVE-2023-33246: Apache RocketMQ: Possible remote code execution vulnerability when using the update configuration function
In CISA’s Known Exploited Vulnerabilities catalog: Apache RocketMQ Command Execution Vulnerability.
Added , federal remediation due . Known ransomware use: Unknown.
Required action: Apply mitigations per vendor instructions or discontinue use of the product if mitigations are unavailable.
Description
For RocketMQ versions 5.1.0 and below, under certain conditions, there is a risk of remote command execution. Several components of RocketMQ, including NameServer, Broker, and Controller, are leaked on the extranet and lack permission verification, an attacker can exploit this vulnerability by using the update configuration function to execute commands as the system users that RocketMQ is running as. Additionally, an attacker can achieve the same effect by forging the RocketMQ protocol content. To prevent these attacks, users are recommended to upgrade to version 5.1.1 or above for using RocketMQ 5.x or 4.9.6 or above for using RocketMQ 4.x .
Vector CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H · CWE-94
Status incidents that name it
No tracked status incident names this CVE.
Affected vendors and products
Apache Software Foundation: Apache RocketMQ
References
- CVE record on cve.org (opens in new tab)
- NVD entry (opens in new tab)
- packetstormsecurity.com/files/173339/Apache-RocketMQ-5.1.0-Arbitrary-Code-Injection.html (opens in new tab)
- lists.apache.org/thread/1s8j2c8kogthtpv3060yddk03zq0pxyp (opens in new tab)
- www.openwall.com/lists/oss-security/2023/07/12/1 (opens in new tab)
- CVE records from the CVE Program (cve.org). CVE® is a registered trademark of The MITRE Corporation. (opens in new tab)
- This product uses data from the NVD API but is not endorsed or certified by the NVD. (opens in new tab)
- Known Exploited Vulnerabilities catalog from CISA. (opens in new tab)
- EPSS scores from FIRST (Exploit Prediction Scoring System). (opens in new tab)