CVE-2019-11580: Atlassian Crowd and Crowd Data Center Remote Code Execution Vulnerability
In CISA’s Known Exploited Vulnerabilities catalog: Atlassian Crowd and Crowd Data Center Remote Code Execution Vulnerability.
Added , federal remediation due . Known ransomware use: Known.
Required action: Apply updates per vendor instructions.
Description
Atlassian Crowd and Crowd Data Center had the pdkinstall development plugin incorrectly enabled in release builds. Attackers who can send unauthenticated or authenticated requests to a Crowd or Crowd Data Center instance can exploit this vulnerability to install arbitrary plugins, which permits remote code execution on systems running a vulnerable version of Crowd or Crowd Data Center. All versions of Crowd from version 2.1.0 before 3.0.5 (the fixed version for 3.0.x), from version 3.1.0 before 3.1.6 (the fixed version for 3.1.x), from version 3.2.0 before 3.2.8 (the fixed version for 3.2.x), from version 3.3.0 before 3.3.5 (the fixed version for 3.3.x), and from version 3.4.0 before 3.4.4 (the fixed version for 3.4.x) are affected by this vulnerability.
Vector CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Status incidents that name it
No tracked status incident names this CVE.
Affected vendors and products
Atlassian: Crowd
References
- CVE record on cve.org (opens in new tab)
- NVD entry (opens in new tab)
- packetstormsecurity.com/files/163810/Atlassian-Crowd-pdkinstall-Remote-Code-Execution.html (opens in new tab)
- jira.atlassian.com/browse/CWD-5388 (opens in new tab)
- www.securityfocus.com/bid/108637 (opens in new tab)
- CVE records from the CVE Program (cve.org). CVE® is a registered trademark of The MITRE Corporation. (opens in new tab)
- This product uses data from the NVD API but is not endorsed or certified by the NVD. (opens in new tab)
- Known Exploited Vulnerabilities catalog from CISA. (opens in new tab)
- EPSS scores from FIRST (Exploit Prediction Scoring System). (opens in new tab)