# CVE-2026-40155: Auth0 Next.js SDK has Improper Proxy Cache Lookup

> CVE-2026-40155: Auth0 Next.js SDK has Improper Proxy Cache Lookup. CVSS 5.4 (CVSS 3.1).

Canonical: https://rewindex.com/cve/CVE-2026-40155
Last updated: 2026-06-17T10:44:47Z

- Published: 2026-04-17 20:54 UTC · Updated: 2026-06-17 10:44 UTC · Assigner: GitHub\_M
- CVSS: 5.4 (CVSS 3.1) · Severity: Medium · Vector: CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:U/C:H/I:L/A:N
- EPSS: 0.21%, 12th percentile (scored 2026-10-25)
- CISA KEV: no
- CWE: CWE-362, CWE-863

## Description

The Auth0 Next.js SDK is a library for implementing user authentication in Next.js applications. In versions 4.12.0 through 4.17.1, simultaneous requests that trigger a nonce retry may cause the proxy cache fetcher to perform improper lookups for the token request results. Users are affected if their project uses both the vulnerable versions and the proxy handler /me/\* and /my-org/\* with DPoP enabled. This issue has been fixed in version 4.18.0.

## Affected vendors and products

- auth0: nextjs-auth0

## Tracked companies

- [Auth0](https://rewindex.com/company/auth0.md)

## References

- [CVE record on cve.org](https://www.cve.org/CVERecord?id=CVE-2026-40155)
- [NVD entry](https://nvd.nist.gov/vuln/detail/CVE-2026-40155)
- [https://github.com/auth0/nextjs-auth0/commit/98c36dc306970c2230ea1a32efef431d29b99978](https://github.com/auth0/nextjs-auth0/commit/98c36dc306970c2230ea1a32efef431d29b99978)
- [https://github.com/auth0/nextjs-auth0/releases/tag/v4.18.0](https://github.com/auth0/nextjs-auth0/releases/tag/v4.18.0)
- [https://github.com/auth0/nextjs-auth0/security/advisories/GHSA-xq8m-7c5p-c2r6](https://github.com/auth0/nextjs-auth0/security/advisories/GHSA-xq8m-7c5p-c2r6)

---

_Sources: CVE records from the CVE Program (cve.org). CVE® is a registered trademark of The MITRE Corporation. (https://www.cve.org/) This product uses data from the NVD API but is not endorsed or certified by the NVD. (https://nvd.nist.gov/) Known Exploited Vulnerabilities catalog from CISA. (https://www.cisa.gov/known-exploited-vulnerabilities-catalog) EPSS scores from FIRST (Exploit Prediction Scoring System). (https://www.first.org/epss/)_


---
Canonical: https://rewindex.com/cve/CVE-2026-40155 · Markdown: https://rewindex.com/cve/CVE-2026-40155.md · JSON: https://rewindex.com/api/v1/cves/CVE-2026-40155 · Data licensed CC BY 4.0 (https://creativecommons.org/licenses/by/4.0/) · Generated 2026-10-26T02:14:53.489Z
