# CVE-2026-27601: Underscore.js has unlimited recursion in _.flatten and _.isEqual, potential for DoS attack

> CVE-2026-27601: Underscore.js has unlimited recursion in _.flatten and _.isEqual, potential for DoS attack. CVSS 5.9 (CVSS 3.1).

Canonical: https://rewindex.com/cve/CVE-2026-27601
Last updated: 2026-06-17T10:27:22Z

- Published: 2026-03-03 22:38 UTC · Updated: 2026-06-17 10:27 UTC · Assigner: GitHub\_M
- CVSS: 5.9 (CVSS 3.1) · Severity: Medium · Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H
- EPSS: 0.96%, 61th percentile (scored 2026-10-25)
- CISA KEV: no
- CWE: CWE-770

## Description

Underscore.js is a utility-belt library for JavaScript. Prior to 1.13.8, the \_.flatten and \_.isEqual functions use recursion without a depth limit. Under very specific conditions, detailed below, an attacker could exploit this in a Denial of Service (DoS) attack by triggering a stack overflow. Untrusted input must be used to create a recursive datastructure, for example using JSON.parse, with no enforced depth limit. The datastructure thus created must be passed to \_.flatten or \_.isEqual. In the case of \_.flatten, the vulnerability can only be exploited if it is possible for a remote client to prepare a datastructure that consists of arrays at all levels AND if no finite depth limit is passed as the second argument to \_.flatten. In the case of \_.isEqual, the vulnerability can only be exploited if there exists a code path in which two distinct datastructures that were submitted by the same remote client are compared using \_.isEqual. For example, if a client submits data that are stored in a database, and the same client can later submit another datastructure that is then compared to the data that were saved in the database previously, OR if a client submits a single request, but its data are parsed twice, creating two non-identical but equivalent datastructures that are then compared. Exceptions originating from the call to \_.flatten or \_.isEqual, as a result of a stack overflow, are not being caught. This vulnerability is fixed in 1.13.8.

## Affected vendors and products

- jashkenas: underscore

## Tracked companies

- [Confluence](https://rewindex.com/company/confluence.md)

## References

- [CVE record on cve.org](https://www.cve.org/CVERecord?id=CVE-2026-27601)
- [NVD entry](https://nvd.nist.gov/vuln/detail/CVE-2026-27601)
- [https://github.com/jashkenas/underscore/commit/411e222eb0ca5d570cc4f6315c02c05b830ed2b4](https://github.com/jashkenas/underscore/commit/411e222eb0ca5d570cc4f6315c02c05b830ed2b4)
- [https://github.com/jashkenas/underscore/commit/a6e23ae9647461ec33ad9f92a2ecfc220eea0a84](https://github.com/jashkenas/underscore/commit/a6e23ae9647461ec33ad9f92a2ecfc220eea0a84)
- [https://github.com/jashkenas/underscore/security/advisories/GHSA-qpx9-hpmf-5gmw](https://github.com/jashkenas/underscore/security/advisories/GHSA-qpx9-hpmf-5gmw)

---

_Sources: CVE records from the CVE Program (cve.org). CVE® is a registered trademark of The MITRE Corporation. (https://www.cve.org/) This product uses data from the NVD API but is not endorsed or certified by the NVD. (https://nvd.nist.gov/) Known Exploited Vulnerabilities catalog from CISA. (https://www.cisa.gov/known-exploited-vulnerabilities-catalog) EPSS scores from FIRST (Exploit Prediction Scoring System). (https://www.first.org/epss/)_


---
Canonical: https://rewindex.com/cve/CVE-2026-27601 · Markdown: https://rewindex.com/cve/CVE-2026-27601.md · JSON: https://rewindex.com/api/v1/cves/CVE-2026-27601 · Data licensed CC BY 4.0 (https://creativecommons.org/licenses/by/4.0/) · Generated 2026-10-26T03:10:04.576Z
