# CVE-2026-15810: Cross-Site Scripting (XSS) in Looker allows Admin Account Takeover

> CVE-2026-15810: Cross-Site Scripting (XSS) in Looker allows Admin Account Takeover. CVSS 8.7 (CVSS 4.0).

Canonical: https://rewindex.com/cve/CVE-2026-15810
Last updated: 2026-10-24T13:10:00Z

- Published: 2026-07-24 11:04 UTC · Updated: 2026-10-24 13:10 UTC · Assigner: GoogleCloud
- CVSS: 8.7 (CVSS 4.0) · Severity: High
- EPSS: 0.45%, 39th percentile (scored 2026-10-25)
- CISA KEV: no
- CWE: CWE-79

## Description

A Cross-Site Scripting (XSS) vulnerability in Google Cloud Looker versions prior to 25.6.103, 25.12.65, 25.18.68, 26.0.66, 26.2.47, 26.4.36, 26.6.28, and 26.8.7 on Looker-hosted and Self-hosted allows an attacker to execute arbitrary JavaScript leading to administrative account takeover using a maliciously crafted URL. Looker-hosted and Self-hosted were found to be vulnerable. This issue has already been mitigated for Looker-hosted instances. No user action is required for these. Self-hosted instances must be upgraded to the patched versions: 25.6.103+, 25.12.65+, 25.18.68+, 26.0.66+, 26.2.47+, 26.4.36+, 26.6.28+, or 26.8.7+.

## Affected vendors and products

- Google Cloud: Looker

## Tracked companies

- [Google Cloud](https://rewindex.com/company/google-cloud.md)

## References

- [CVE record on cve.org](https://www.cve.org/CVERecord?id=CVE-2026-15810)
- [NVD entry](https://nvd.nist.gov/vuln/detail/CVE-2026-15810)
- [https://docs.cloud.google.com/looker/docs/release-notes\#July\_22\_2026](https://docs.cloud.google.com/looker/docs/release-notes#July_22_2026)
- [https://docs.cloud.google.com/support/bulletins\#gcp-2026-049](https://docs.cloud.google.com/support/bulletins#gcp-2026-049)

---

_Sources: CVE records from the CVE Program (cve.org). CVE® is a registered trademark of The MITRE Corporation. (https://www.cve.org/) This product uses data from the NVD API but is not endorsed or certified by the NVD. (https://nvd.nist.gov/) Known Exploited Vulnerabilities catalog from CISA. (https://www.cisa.gov/known-exploited-vulnerabilities-catalog) EPSS scores from FIRST (Exploit Prediction Scoring System). (https://www.first.org/epss/)_


---
Canonical: https://rewindex.com/cve/CVE-2026-15810 · Markdown: https://rewindex.com/cve/CVE-2026-15810.md · JSON: https://rewindex.com/api/v1/cves/CVE-2026-15810 · Data licensed CC BY 4.0 (https://creativecommons.org/licenses/by/4.0/) · Generated 2026-10-26T03:12:03.489Z
