# CVE-2025-61591: Cursor CLI's Cursor Agent MCP OAuth2 Communication is Vulnerable to Remote Code Execution

> CVE-2025-61591: Cursor CLI's Cursor Agent MCP OAuth2 Communication is Vulnerable to Remote Code Execution. CVSS 8.8 (CVSS 3.1).

Canonical: https://rewindex.com/cve/CVE-2025-61591
Last updated: 2026-10-19T17:10:00Z

- Published: 2025-10-03 16:44 UTC · Updated: 2026-10-19 17:10 UTC · Assigner: GitHub\_M
- CVSS: 8.8 (CVSS 3.1) · Severity: High · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
- EPSS: 1.2%, 67th percentile (scored 2026-10-25)
- CISA KEV: no
- CWE: CWE-78

## Description

Cursor is a code editor built for programming with AI. In versions 1.7 and below, when MCP uses OAuth authentication with an untrusted MCP server, an attacker can impersonate a malicious MCP server and return crafted, maliciously injected commands during the interaction process, leading to command injection and potential remote code execution. If chained with an untrusted MCP service via OAuth, this command injection vulnerability could allow arbitrary code execution on the host by the agent. This can then be used to directly compromise the system by executing malicious commands with full user privileges. This issue does not currently have a fixed release version, but there is a patch, 2025.09.17-25b418f.

## Affected vendors and products

- cursor: cursor

## Tracked companies

- [Cursor](https://rewindex.com/company/cursor.md)

## References

- [CVE record on cve.org](https://www.cve.org/CVERecord?id=CVE-2025-61591)
- [NVD entry](https://nvd.nist.gov/vuln/detail/CVE-2025-61591)
- [https://github.com/cursor/cursor/security/advisories/GHSA-wj33-264c-j9cq](https://github.com/cursor/cursor/security/advisories/GHSA-wj33-264c-j9cq)

---

_Sources: CVE records from the CVE Program (cve.org). CVE® is a registered trademark of The MITRE Corporation. (https://www.cve.org/) This product uses data from the NVD API but is not endorsed or certified by the NVD. (https://nvd.nist.gov/) Known Exploited Vulnerabilities catalog from CISA. (https://www.cisa.gov/known-exploited-vulnerabilities-catalog) EPSS scores from FIRST (Exploit Prediction Scoring System). (https://www.first.org/epss/)_


---
Canonical: https://rewindex.com/cve/CVE-2025-61591 · Markdown: https://rewindex.com/cve/CVE-2025-61591.md · JSON: https://rewindex.com/api/v1/cves/CVE-2025-61591 · Data licensed CC BY 4.0 (https://creativecommons.org/licenses/by/4.0/) · Generated 2026-10-26T02:13:06.353Z
