# CVE-2025-54988: Apache Tika PDF parser module: XXE vulnerability in PDFParser's handling of XFA

> CVE-2025-54988: Apache Tika PDF parser module: XXE vulnerability in PDFParser's handling of XFA. CVSS 8.4 (CVSS 3.1).

Canonical: https://rewindex.com/cve/CVE-2025-54988
Last updated: 2026-06-17T09:41:04Z

- Published: 2025-08-20 20:08 UTC · Updated: 2026-06-17 09:41 UTC · Assigner: apache
- CVSS: 8.4 (CVSS 3.1) · Severity: High · Vector: CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- EPSS: 47.9%, 99th percentile (scored 2026-10-25)
- CISA KEV: no
- CWE: CWE-611

## Description

Critical XXE in Apache Tika (tika-parser-pdf-module) in Apache Tika 1.13 through and including 3.2.1 on all platforms allows an attacker to carry out XML External Entity injection via a crafted XFA file inside of a PDF. An attacker may be able to read sensitive data or trigger malicious requests to internal resources or third-party servers. Note that the tika-parser-pdf-module is used as a dependency in several Tika packages including at least: tika-parsers-standard-modules, tika-parsers-standard-package, tika-app, tika-grpc and tika-server-standard. Users are recommended to upgrade to version 3.2.2, which fixes this issue.

## Affected vendors and products

- Apache Software Foundation: Apache Tika PDF parser module

## Tracked companies

- [Confluence](https://rewindex.com/company/confluence.md)
- [Jira](https://rewindex.com/company/jira.md)

## References

- [CVE record on cve.org](https://www.cve.org/CVERecord?id=CVE-2025-54988)
- [NVD entry](https://nvd.nist.gov/vuln/detail/CVE-2025-54988)
- [https://lists.apache.org/thread/8xn3rqy6kz5b3l1t83kcofkw0w4mmj1w](https://lists.apache.org/thread/8xn3rqy6kz5b3l1t83kcofkw0w4mmj1w)

---

_Sources: CVE records from the CVE Program (cve.org). CVE® is a registered trademark of The MITRE Corporation. (https://www.cve.org/) This product uses data from the NVD API but is not endorsed or certified by the NVD. (https://nvd.nist.gov/) Known Exploited Vulnerabilities catalog from CISA. (https://www.cisa.gov/known-exploited-vulnerabilities-catalog) EPSS scores from FIRST (Exploit Prediction Scoring System). (https://www.first.org/epss/)_


---
Canonical: https://rewindex.com/cve/CVE-2025-54988 · Markdown: https://rewindex.com/cve/CVE-2025-54988.md · JSON: https://rewindex.com/api/v1/cves/CVE-2025-54988 · Data licensed CC BY 4.0 (https://creativecommons.org/licenses/by/4.0/) · Generated 2026-10-26T03:12:13.064Z
