# CVE-2025-29927: Authorization Bypass in Next.js Middleware

> CVE-2025-29927: Authorization Bypass in Next.js Middleware. CVSS 9.1 (CVSS 3.1).

Canonical: https://rewindex.com/cve/CVE-2025-29927
Last updated: 2026-06-17T09:05:53Z

- Published: 2025-03-21 14:34 UTC · Updated: 2026-06-17 09:05 UTC · Assigner: GitHub\_M
- CVSS: 9.1 (CVSS 3.1) · Severity: Critical · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N
- EPSS: 99.2%, 100th percentile (scored 2026-10-25)
- CISA KEV: no
- CWE: CWE-285

## Description

Next.js is a React framework for building full-stack web applications. Starting in version 1.11.4 and prior to versions 12.3.5, 13.5.9, 14.2.25, and 15.2.3, it is possible to bypass authorization checks within a Next.js application, if the authorization check occurs in middleware. If patching to a safe version is infeasible, it is recommend that you prevent external user requests which contain the x-middleware-subrequest header from reaching your Next.js application. This vulnerability is fixed in 12.3.5, 13.5.9, 14.2.25, and 15.2.3.

## Affected vendors and products

- vercel: next.js

## Tracked companies

- [Vercel](https://rewindex.com/company/vercel.md)

## References

- [CVE record on cve.org](https://www.cve.org/CVERecord?id=CVE-2025-29927)
- [NVD entry](https://nvd.nist.gov/vuln/detail/CVE-2025-29927)
- [https://github.com/vercel/next.js/commit/52a078da3884efe6501613c7834a3d02a91676d2](https://github.com/vercel/next.js/commit/52a078da3884efe6501613c7834a3d02a91676d2)
- [https://github.com/vercel/next.js/commit/5fd3ae8f8542677c6294f32d18022731eab6fe48](https://github.com/vercel/next.js/commit/5fd3ae8f8542677c6294f32d18022731eab6fe48)
- [https://github.com/vercel/next.js/releases/tag/v12.3.5](https://github.com/vercel/next.js/releases/tag/v12.3.5)
- [https://github.com/vercel/next.js/releases/tag/v13.5.9](https://github.com/vercel/next.js/releases/tag/v13.5.9)
- [https://github.com/vercel/next.js/security/advisories/GHSA-f82v-jwr5-mffw](https://github.com/vercel/next.js/security/advisories/GHSA-f82v-jwr5-mffw)

---

_Sources: CVE records from the CVE Program (cve.org). CVE® is a registered trademark of The MITRE Corporation. (https://www.cve.org/) This product uses data from the NVD API but is not endorsed or certified by the NVD. (https://nvd.nist.gov/) Known Exploited Vulnerabilities catalog from CISA. (https://www.cisa.gov/known-exploited-vulnerabilities-catalog) EPSS scores from FIRST (Exploit Prediction Scoring System). (https://www.first.org/epss/)_


---
Canonical: https://rewindex.com/cve/CVE-2025-29927 · Markdown: https://rewindex.com/cve/CVE-2025-29927.md · JSON: https://rewindex.com/api/v1/cves/CVE-2025-29927 · Data licensed CC BY 4.0 (https://creativecommons.org/licenses/by/4.0/) · Generated 2026-10-26T02:15:46.176Z
