# CVE-2025-24813: Apache Tomcat: Potential RCE and/or information disclosure and/or information corruption with partial PUT

> CVE-2025-24813: Apache Tomcat: Potential RCE and/or information disclosure and/or information corruption with partial PUT. CVSS 10.0 (CVSS 3.1), in CISA KEV.

Canonical: https://rewindex.com/cve/CVE-2025-24813
Last updated: 2026-06-17T08:59:39Z

- Published: 2025-03-10 16:44 UTC · Updated: 2026-06-17 08:59 UTC · Assigner: apache
- CVSS: 10.0 (CVSS 3.1) · Severity: Critical · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H
- EPSS: 99.9%, 100th percentile (scored 2026-10-25)
- CISA KEV: yes, added 2025-04-01, federal due date 2025-04-22, ransomware use: Unknown
- CWE: CWE-44, CWE-502

## Description

Path Equivalence: 'file.Name' (Internal Dot) leading to Remote Code Execution and/or Information disclosure and/or malicious content added to uploaded files via write enabled Default Servlet in Apache Tomcat. This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.2, from 10.1.0-M1 through 10.1.34, from 9.0.0.M1 through 9.0.98. The following versions were EOL at the time the CVE was created but are  known to be affected: 8.5.0 though 8.5.100. Other, older, EOL versions  may also be affected. If all of the following were true, a malicious user was able to view       security sensitive files and/or inject content into those files: - writes enabled for the default servlet (disabled by default) - support for partial PUT (enabled by default) - a target URL for security sensitive uploads that was a sub-directory of a target URL for public uploads - attacker knowledge of the names of security sensitive files being uploaded - the security sensitive files also being uploaded via partial PUT If all of the following were true, a malicious user was able to       perform remote code execution: - writes enabled for the default servlet (disabled by default) - support for partial PUT (enabled by default) - application was using Tomcat's file based session persistence with the default storage location - application included a library that may be leveraged in a deserialization attack Users are recommended to upgrade to version 11.0.3, 10.1.35 or 9.0.99, which fixes the issue.

## CISA required action

Apply mitigations per vendor instructions, follow applicable BOD 22-01 guidance for cloud services, or discontinue use of the product if mitigations are unavailable.

## Affected vendors and products

- Apache Software Foundation: Apache Tomcat

## References

- [CVE record on cve.org](https://www.cve.org/CVERecord?id=CVE-2025-24813)
- [NVD entry](https://nvd.nist.gov/vuln/detail/CVE-2025-24813)
- [https://lists.apache.org/thread/j5fkjv2k477os90nczf2v9l61fb0kkgq](https://lists.apache.org/thread/j5fkjv2k477os90nczf2v9l61fb0kkgq)

---

_Sources: CVE records from the CVE Program (cve.org). CVE® is a registered trademark of The MITRE Corporation. (https://www.cve.org/) This product uses data from the NVD API but is not endorsed or certified by the NVD. (https://nvd.nist.gov/) Known Exploited Vulnerabilities catalog from CISA. (https://www.cisa.gov/known-exploited-vulnerabilities-catalog) EPSS scores from FIRST (Exploit Prediction Scoring System). (https://www.first.org/epss/)_


---
Canonical: https://rewindex.com/cve/CVE-2025-24813 · Markdown: https://rewindex.com/cve/CVE-2025-24813.md · JSON: https://rewindex.com/api/v1/cves/CVE-2025-24813 · Data licensed CC BY 4.0 (https://creativecommons.org/licenses/by/4.0/) · Generated 2026-10-26T02:13:29.251Z
